About Qalyptus Documentation

Remote server returned an error (500) internal error

Hi,

I have tried qalyptus desktop in the qliksense enterprise installed server and while creating connection we are getting below error. I have already verified the ports and all the required ports opened as per documentation.

Hi @s.premvihari,

The error is returned by Qlik Sense.
The reason can be in the default Qlik Sense Proxy you are using.
Please can check if your default proxy does not have a prefix.

In Qalyptus Desktop, when you enter the Qlik Sense address without any prefix (subdomain.domain.com), Qalyptus will use the proxy without a prefix (not your default proxy).

Note that Qalyptus support using proxies. Example: subdomain.domain.com/external

Please check your proxies and change the Qlik sense address in Qalyptus Desktop if needed and let me know.

Thanks
Jeremie

Hi,

Thanks for reply. I have reverified virtual proxy settings and ensure default proxy doesn’t have any prefix but now i’m getting below error

image

Hi @s.premvihari,

Good news and bad news with this new error :wink:
The good news is that Qalyptus can now connect to your Qlik Sense (the first error is disappeared)
The bad news is there is an error when Qalyptus try to get the list of Qalik Sense app.

The data format of the last reload time is not recognized as a valid date.
Please can you give me the version of your Qlik Sense?
And share the Last reload date format?

BTW, we will publish a patch to fix this issue.

Thanks
Jeremie

Thanks for swift response. The error i have received in September 2020 version and below is last reload date format

In the meanwhile i have tried desktop in another server where we have qliksense Feb 2021 and its working as expected.

Thank you for all the information @s.premvihari.
Our technical team was very responsive. I just emailed you with a new version of Qalyptus Desktop that fixes the problem.

Let me know if everything works as expected now.

Thanks
Jeremie

Hi @jeremie_m,

Please advise how fix below error. when tried to preview the templates designed getting below error. it was happening with all the templates.

Hi @s.premvihari,
I can see that the previous problem is solved. Great!
For the issue: “The CancellationTokenSource has been disposed”, please make sure that the option “Extended security environment” is not checked in the virtual proxy you are using with Qalyptus (Virtual Proxy > Advanced). See below.

If you need to check the option for your default proxy, you can create a new Virtual proxy for Qalyptus with, for example, a prefix: qalyptus.
and when you create your connection in Qalyptus, add the prefix to the Qlik Sense address like this:
https://your-qlik-sense-url.com/qalyptus

Please let me know if this fixes the problem.

Thanks
Jeremie